Admob plug-in doesn’t work

I followed the wiki about exporting to iOS. Read multiple forum posts. But I can’t get it to work. I’ve tried multiple things, for a few days now. And after this I can finally release my first game after 2 years. Can somebody please help me with this, I really don’t know what to do anymore.

These are the errors I get in Xcode



Can somebody try to build the game on mac, without the errors. Because I can’t get it running without errors. And if so, fix it. I’m willing to pay.

When i do “cordova platform add ios” in terminal.

The cordova discovers the plugin gdevelop-cordova-admob-plus and then tries to install cordova-admob-plus.

I found in the files gdevelop-cordova-admob-plus and cordova-admob-plus. What is the difference between these two? And is this maybe the cause of the problem?

And how can I change this?

When I add iOS to the project (terminal), admob plug-in fails every time.

I tried to uninstall, install, updating, changing names.

Cocoapods, cordova, nodejs installed.

I’m stuck on this for 2 weeks now, and i really want to release my game now. Can somebody help me with this?