Android export stop loading at 50%

I wanted to test the Android exporter and for some reason this game doesn’t load on my android device: … sp=sharing
It stops at 50%
Could anyone test it to see f it a problem with the game or it a problem with my android device?

This is the Brakeout example from GDevelop, also shared on GDevApp so you can make a copy and export it for your self to see if it makes any different.

I have also tested the Shooter template which is running (at pretty low frame rate) on my android device so I guess the Brakeout game should run as well, but if it not (it a problem with the game/package) there is 2 things that make it different from the shooter template: originally the project is imported from GDevelop, and it using external images from dropbox, don’t know if it actually matters just guessing.


Mine freezes at 50% as well on my android device. My antivirus also gave me a warning with it. I don’t get antivirus issues with other Gdevelop games I tested. It says
“Suspicious file detected - APK:CloudRep [Susp]”

Thanks for the reply,.

Regarding the warning,
it probably warn you because the application is suspicious as it is require permission to access connection to internet, read/write external storage and such, which is normal after all, as it is a game and games need to have access to those permissions in some cases but can be dangerous so you get the warning. Other GDevelop games may not require such permissions, but if it the case I don’t know why this game require and others don’t.

I have uploaded to Virustotal and every antivirus find it clean. … 429714617/

I leave it to 4ian then, maybe he can do something about it.

Thanks again.

I opened the example breakout game bundled with gdevelop.
I compiled it and it worked fine. I don’t know if the gdevapp version is any different, but it worked fine for me :confused:

Never tried to export from GDevelop using IntelXDK, GDevApp is using Crosswalk to export to Android and the GDevApp version is loading images from external storage (dropbox) that need to be downloaded I guess during export process…

Any thoughts on this from the devs by any chance :confused: :imp:

Could you send me by message the link to your game? :smiley:
Maybe a resource that couldn’t be downloaded, making the loading fail.