Bug? Using Alt-Tab breaks text input

I have a game that uses text input.

Users can create and store words on the screen. It had all been going without a hitch until I tried a demo at a presentation (eek!). When I used Alt-Tab to swap from PowerPoint to the game, the text objects disappeared. I make a new object, the text appears, and then as soon as I drag it, it disappears. In debug mode, I can see the object is still there, but the text is deleted (so it is invisible). I type again, and it appears. I drag it, and it disappears. Any ideas?

1 Like

A bug fix has been made today on the text entry.
A problem was causing it to move to position 0;0.

An update to 5.1.149 will be push today.

1 Like

Thanks. Unfortunately, in my case, It’s not moving to position 0;0. However, I do have a condition that tweens it back into position on mouse release. My issue is it deletes the text whenever I drag the object and release the mouse. The object is still in position, it’s just empty. I’ve tried the new update and still have the issue. When I use a new scene and a simple text creation object, it works, but in my game, it doesn’t. It may be something in my code, but I don’t call on the alt-tab combination for anything in the game.

1 Like

A bit more detail about the issue:

  1. I have conditions set up to allow re-editing of existing text on mouse up.
  2. Mouse up sets the text in memory of the capture object to “”
  3. Then any key press re-activates the capture of text and, the text is replaced with the new text

After alt-tab

  1. Mouse up sets the text in memory of the capture object to “” and sets the text object to “”
    My guess is that the “press any key” condition is bypassed?
1 Like