Cannot move object on scene (with mouse)

Hi, I just try gdevelop, and the first time I tried it was fantastic, but something happened I couldn’t move all the objects(with mouse), is there a solution?

I moved your post to a more adequate topic, as it sounds like you just don’t know how to do it than a bug.
There are multiple ways you can make an object movable with the mouse. You can use the draggable behavior, apply on every frame an instant force to the mouse position, tween to mouse position… etc.

1 Like

hi, thanks for the reply, I’ve tried it but still can’t move the object, I don’t know why it could be like that, for the first time trying everything was fine but after a few days I found an error like that, the object freezes I can’t do nothing for the objects,(sory for my bad english)

Hello Maruf,
I found this too when creating a thumb control. I found my issue was that everything was moving in X and Y coordinates but the background image was frozen which gave the impression that nothing was moving.
To see if this is the case you can create a sprite object and apply a force i.e. 100 pixels at angle 270. Attach the camera (Center on object) to that object and you should see all other objects move down while the background and your new object stay still.
If this happens, you may have the Background image not on the base layer. Attach it to the base layer and give it the lowest Z order number i.e.-10.
Maybe someone can help explain this phenomenon but that worked for me.
Also if you have controller GUI issues when using cameras tracking objects on other layers, i.e. keeping players on a player layer and trying to center the camera on the player that way, you may find it best to put everything on the Base Layer.

I am a hobyist and to avoid these bugs now, I create everything in the game on the base layer, and controls etc on a UI Layer.
This helps prevent these issues. Once everything is working then you can divide and clean up later.

Hope That Helps