Can't download GDevelop

I have been trying to download GDevelop for the last 2 days but it always ends up with errors, the speed decreases to 0 and can’t resume, retry ends up the same way, today, i am downloading right now (this is the 3rd attempt … and it also failed), i want the, i tried to download exe setup also, but the same issue.

I have tried downloading in laptop with windows 7 (twice), from my android mobile (once) and i can’t remember how many times from my laptop with lubuntu (32 bit). I downloaded uget and it says message: server error 403

Any attempt to resume in uget ends up successfully but with a corrupt zip.

My download speed is terrible (i don’t mean this website in particular … my whole connection is), some websites give 100 kbps to 150 kbps, others give usual 20 - 25 kbps, so you can understand how shitty i feel when i can’t download 108 mb after tens of attempts during 2 days (while i have downloaded about ~5 gb this week from torrent) but this is getting quite annoying.

Why is this happening and what should i do? Is there (can you make) a torrent link so i can download with torrent?


you need 7zip installed to open 7z files.

Oh… thanks… i just checked the file in Windows 7 and the one i downloaded with uget actually worked, others really are corrupt.