Can't Save or Preview

So, I was messing around, trying my hand at procedural level creation, and when i got something i liked, The preview never finished loading, the screen stayed black. I thought “Hmm, that’s weird”, so I tried saving, so i could safely restart Gdevelop. When i Clicked save, an error message popped up, saying it could not save.

Try to press CTRL + SHIFT + I in the game preview and screenshot the console tab, there is maybe the error.
That could help to see what happend to the preview.

For the saving use “save as” somewhere else for now.

I tried the save as, and it wouldnt work anyway. I also tried opening the file with another instance of gdevelop, and it said the file was corrupted, so i copied the event to a new project. I still have the original, if you want to take a look, though I doubt it’ll do any good.
Edit: luckily, it was a small projects, with very little to copy over

You can explain everything you mention me here, to the engineers, they will take a look to the corrupted file.
Open an issue here with your file.