Command option does not seem to be working on Yarn for this specific problem (SOLVED)

Hey there! I’m currently struggling with options in my game including Yarn. Firstly, I’ve been able to have all options and choices and selections work properly, but this one is different.

Essentially, you’re paying money to donate to a fund that one of the NPCs are hosting. You can click ‘yes’ or ‘no’, but I want it to check when you select ‘yes’ if you have enough money to actually make the donation. And if you do have enough money, then it’ll switch to a different dialogue node then if you didn’t have enough money. This is what I attempted.

When I run the game, it goes through the dialogue just fine, and ends at ‘Okay, let’s see!’ and does not switch over to the other nodes I used under the Command function. I’m sure it’s an easy fix, but I searched the forums and couldn’t find an answer to my specific question, so I decided to try it out myself here.

Is there any suggestions on what I can do? It doesn’t seem to be removing money from my inventory either, so I suspect it isn’t actually using the Command at all.

Thank you very much!

I see you marked this as solved. Can you make a quick post to let readers know what you did to resolve the issue?


I looked around on youtube, and watched this particular video: Yarn variables and conditional statements | Dialogue in GDevelop with Yarn - YouTube

I already timestamped it for help, but essentially I learned a bit more into detail about conditional formatting for yarn, specifically the if/elseif statements for text. So if you don’t have enough money, it wouldn’t actually move onto another branch at all, it would just end there.