Deleting object folders crashes scene editor

I created two object folders today (I haven’t used this new feature before). One folder was a sub-folder of the other. I tried to delete the sub-folder and got this error message. The folders were both still empty.

I had to restart GDevelop to get the scene editor back.

Also, I can’t create object folders for global objects. The new folder button only creates them under scene objects and I can’t drag those into the global section.


Edit: Upon reloading GDevelop, I tried creating an object folder (no sub-folder this time). I tried deleting the empty folder and the scene editor crashed again. I’ll avoid using this feature for now.

I can’t get this to crash on Windows 10 or Zorin os. I’ve tried multiple things, even enabling preference settings that I thought you might have (save on preview, open last file used, etc), deleting via delete key or right clicking, saving first before deleting. They might have fixed it already. Are you on 5.3.180?

Oh but mine won’t drag into global either though.

Hi Lucky-j.

The crashing happened again this morning (Sunday) when I created and then deleted a folder in global objects for the first time* (yesterday’s bug post was when I created them under scene objects). After restarting GDevelop, I was able to create and delete one in the global list without issue. I am also now able to create and delete them in the scene objects list too. The problem is either intermittent or it has somehow resolved itself. I was already at 5.3.180, so that isn’t it. I’m on Windows 11.

Are the settings you mentioned an issue for some people? I have both of those things on.

*So it turns out I was being a dummy and you can create folders in global. But you have to have a global object - any global object - selected before you click the new folder button. If you have nothing selected, it will create a folder under scene objects by default. Also, being able to drag a folder of scene objects into global, or vice versa, wouldn’t make sense and I understand why that isn’t possible. The folder I was trying to drag was empty, but I get why GDevelop doesn’t allow it.

Hi Pixels. No no I don’t think the settings are an issue (except possibly the watch for changes if you are using git for version control, but that was another issiue I had read). But since I couldn’t make it crash I was just trying all sorts of things to replicate it. And I just figured those settings were probably the most common for people to have on, so I turned them on in case that was it.

Now I’m wondering if it’s a Windows 11 conflict. But hopefully it statys intermittent. And being forewarned of the possibility, you can save your project before deleting a folder just in case haha.

Thanks for letting me know how to make the global folder. It seems like a pretty handy feature to have.

I am going to have a very geeky time sorting my objects into carefully named folders this week :upside_down_face: (if the functionality behaves).

Thanks for confirming about the settings. I rarely look at them and haven’t changed any lately.

Win 11 has been around for 2 years now and I wouldn’t expect any issue because of that at this point. GDevelop has been fine on it since I got a new PC last April with Win 11 pre-installed. But you never know.

1 Like