Draggable physics behavior causing black screen

i just started a new project, and wanted to test out the draggable physic behavior. I created an object (a square) gave it a physics2.0 and the draggable physic behavior and tried to run a preview but the screen is just black and doesn’t load the game. Is there something i did or haven’t done that’s causing this to happen?

Do you have any events? Can you screen shot them if so?

And if you run in preview, open developer tools (press ctrl + shift + i), and select console tab, are there any error messages?

no events just yet, but i just tried the did dev tool and it does have a few errors, it says “Assertion failed: bd->position.IsValid()”. its strange because it just feels like the options broken. even if i remove everything except for the piskel-drawn box, and the draggable physics behavior it fails, but whenever i remove just the draggable physics behavior it becomes playable again.

I’ve just tried the same - created a new project, created a sprite with physics2 and physics drag behaviour. It runs fine.

Did you create the project from the blank template?

1 Like

Same problem for me, I tried also uselessly Physics 1.

I tried an old project and a new one blank :thinking:

1 Like

same problem… for me too

1 Like

Hey all,

The physics 2.0 behavior has a bug in version 5.0.142/143, it is fixed in the newest release. It won’t be on auto-updators yet, but you can get it here: Release 5.0.144 · 4ian/GDevelop · GitHub


Really thanks, I’ll try soon! :smiley: