Editor keeps crashing since recent update

I installed the latest version of gdevelop today and the first issue I noticed was that the lighting layer refused to show on the editor yet it worked fine in the game. i did everything from replacing the lighting txtures to creating a new light object, nothing worked.

Now, much later after I had closed the engine. I opened gdevelop to continue working on my game and was met with this.

I restarted gdevelop, and now instead of it showing that message, it just shows me a black screen and it always happens anytime I open a scene that has lighting layers enabled.

Hi @VCDGamer ,
Sorry for the inconvenience.
Could you try to open the developer tools (Ctrl + Shift + i) and take a screenshot of the console?

Never Mind. The issue has stopped. It turns out the light objects I had in my editor were too large(20000px). and there were too many of them in the scene. But as I reduced the size of the light objects, the issue stopped.

Well I hope it did not impact too much how your game is done!

1 Like