Event sheet clarity suggestions - making GD more friendly

Hi, sorry for the harsh criticism. I think the wording in the event sheet can be improved to be more clear - it is confusing at some places. This is for the english version of the software.

Some suggestions on wording -
Flip the object horizontally-- options–>activate flipping–> yes or no. Using yes or no in a pop up dialogue can be confusing and sounds like a prompt choice rather than a state.
Instead of yes or no you can say “true” “false” . Instead of “activate flipping” you can say “Object is flipped”

in the “by object type” , the left bottom list- you have “all objects” and “Sprite”. Instead of saying “All objects” , you can say “logic” or something more descriptive of what you find inside it. When it says “all objects” what do you mean? All objects in the scene? All of this object’s conditions/actions? It’s too vague

On organization:
“The cursor is on an object” condition would be easier to find in “all conditions–>mouse” with the other mouse events. You select which object in the condition options anyways.


  • some of the naming in the event sheet is excessively long. For example- instead of saying “scale of width” you can say only “width” or “width scale”. Try to be more minimalist when expressing logic. Less words, better picked words to fit the description - in the right order.

“do 1 to the number of current animation” should be “set current animation to clip 1” .

I will continue to post stuff that I find here. Hope this helps :slight_smile:
I will update this post with more stuff later on. Please share yours. Let’s compile a number of suggestions to make the wording clearer to non programmers! and easier to find by programmers

Gamedevelop- 3.3.70

Trigger once- description

It says:

"Force the actions of the event to be run just once when all the other conditions first becomes true."

There is a grammatical error, also it is a bit unclear. It can say:

"Run events only once, for each time the conditions have been met"

If I knew where the entire english translation’s file is, I could have taken a good look at it. For translation projects I usually use google docs though.

Also what happens when you invert it? Just curious.

I’ve changed the description (just changed the word events for actions, it is more adapted).

Nothing, the condition still works as usual! :slight_smile:

This is awesome :slight_smile:
Would be kind of nice if the “invert” tickbox is not visible on any conditions that do not support it.

Btw is there any reason the undo button in the “events” tab is called “cancel” and not “Undo”?

:astonished: Oops, never seen this error, I’ve renamed it to undo! Thanks!

You have an instance property being named in two ways.You call it “angle” in the object’s instance properties. And then call it “Direction” in the event sheet.
This creates confusion. I expected it to be called angle in the event sheet as well.

In the Event sheet, instead of “direction” property of a sprite, you should call it “Angle” as well. When I tried to find it, it did not find it under that name. You are making the user learn two names to use for the same value to affect.

In general it would be better if you name things consistently across the board and also categorize them consistently. The Properties editor has “Angle” filed under “instance properties”. The event sheet has it filed under “sprite>direction”

The properties editor - the OBJECT NAME property should be made more apparent. In fact it should be on top of all the properties, so you know what the properties editor has currently selected.
This becomes a problem when you have two different objects (not instances) with the exact same sprite. Selecting them in the layout and not having idea which is which, untill finding it in small print written somewhere in the properties editor.
It is also a general rule in software UI. The name of the object that is being edited should be on top of the properties editor.