./ExeLinux: error

Hi there all!

Well I have had problems to compile games with GD, I have Ubuntu 11.10 64 bits installed.
I didn´t create a game myself yet, but I am testing the program possibilities, I read a lot
but I couldn´t find anything related with this problem. I tried to compile some games from
the example folder, no matter what options I choose the compiling process goes ok, with no
errors, but it doesn´t execute the file, I did it by the terminal and this is what happened:

./ExeLinux: error while loading shared libraries: libgdl.so: cannot open shared object file: No such file or directory

Well I copied this file from opt/gamedevelop to the game folder and the error message
changed the necessary shared library, I copied this new one to the game folder too and it showed
another one and so on, but I couldn´t execute the game.

Another thing is if I choose Single Executable File it doesn´t create it, but it produces a folder
with files, like if I pick Simple.

What can be happening?

Thanks in advance!


You have to launch an other file to start the game, not “ExeLinux”, but a file beginning with “Start” (I don’t remember exactly).

Since “the other file” can be named as you want, this has to be shellscript wrapper, not actual executable.

Do not do this, the libgdl.so file used by the editor is not the same that the one used by games. ( In fact, the correct libgdl.so file can be found into GDfolder/Runtime ).

So be sure to compile again an example (to make sure that the compiled game is not corrupted by some bad files like the libgdl.so file designed for the Game Develop executable), and then launch the game using the script “PlayLinux”. :slight_smile:
( In fact, compiled games are including all the necessary dependencies, but you have to launch the games using a script so that Linux can found these dependencies. )

Hi guys, thanks for the replies!

That´s exactly what I am doing, I try to launch the game by the script, not by the ExeLinux, I tried to compile the examples again three or four times and the error is the same.

4ian, there isn´t a PlayLinux script in the folder but one called GameLinux, this is the one, right? Here is a list of the files in the folder:

GameLinux (Script)

Yes, it is indeed this file.

It’s strange that the file libgdl.so is not here. You can try to go into /Runtime and copy the file libgdl.so into your game folder. If the game does not start even with the file libgdl.so copied, paste here the errors displayed by the terminal.

4ian, I went to the GD directory/Runtime, but there was only two files there:

GameLinux (script)

I found libgdl.so inside GD directory, I copied it to the game folder and below is the error message that appeared:

./ExeLinux: error while loading shared libraries: libwx_gtk2u_stc-2.9.so.3: cannot open shared object file: No such file or directory

The error is with another library and if I copy this one to the game folder too the error will occur with another one.

What can be happening?

No, no, this is not the right libgdl.so file, it is not adapted for the games.

A file is missing in the Runtime directory ( and it is libgdl.so, but not the same as the one used by the editor ), so download again GD for Linux and extract it in the same directory so as to be sure that all files are present, and in particular that missing one.

This version I have installed in my computer is from the oficial Ubuntu repositories, I will uninstall it and download the latest one from here.