Export tilemaps bug

When the tilemap is longer than 1500 cells x 8pixels = 12,000 pixels then it starts to disappear for the bottom tilemap as you can see in these images. I have tried to repeat the same tilemap several times from scratch and it always happens the same, it seems that the longer the tilemap is, the more part it disappears. Please help, thank you :slight_smile:

I use the recommended program Tiled. My project is 456x256p and the tilemap is 224p tall.

Try this simple project to test it: https://drive.google.com/file/d/13-WpKMeGs2unCMimGwIV9_bK7oXx7QkS/view?usp=sharing

EDIT: the problem starts from the size < 4000 pixels width

I tried your linked project, but only got an instant crash (black screen).
Can you confirm the version of GDevelop you are running and the necessary steps to reproduce the issue, if any?

1 Like

Yep, a few folks have reported this and I was able to reproduce it. An issue is opened here: Large Tilemaps cut off Horizontally · Issue #4039 · 4ian/GDevelop · GitHub

The only workaround at this point is to split your tilemap into multiple maps that are under 4000x4000 pixels, then make unique tilemap objects for each.

1 Like

I will use that solution, thanks.

I just decided to update my old project, and I found the same problem, only it worked before, the problem is in one of the versions, I will report after the test…

Hello, a new version of GD has been released, could you check if this problem is observed in the new version?
Release 5.0.141 · 4ian/GDevelop (github.com)

I think is not for the tilemaps itself i just the 4096x4096 limit for images.