Game doesn't exit clean: keeps game resolution on desktop

Note: This seems to be more of an issue on my Ubuntu laptop than on Windows.

I’ve been trying to solve this one on my own for a little while now, but I’m stumped for a reliable solution. When I have my game set for fullscreen, then exit, my desktop is still set to the game’s resolution. I tried having it exit fullscreen and then start a short timer to close the game, but about 90% of the time, it doesn’t leave fullscreen. Anybody have suggestions to fix this?

Well, I use Debian and Ubuntu here. On Ubuntu machines( desktop and notebook ) Gdevelop works fine, but I work with XFCE desktop manager. Are you using Unity? Or other desktop environment? Have you cheked your video driver updates?

It can be a lot of things. Need to test all possibilities.

Yes, I am using Unity, but I don’t think it’s a DE issue because I’ve had the same thing happen with other games in other environments, including Windows. I usually keep my video drivers up to date as a rule, so I don’t think that’s where the problem is.

My best guess is that it’s in how the game gets rendered in fullscreen… whether it changes the resolution of the display or stretches itself to fit. In this case, it seems to change the display resolution. I wasn’t worried about that as much, so I mainly just want it to leave fullscreen reliably before closing because that has worked, when the game actually leaves fullscreen, anyway.

You are right. I’ve tested here, and sometimes it happens in a ramdomly way.