Gdevelop not show preview

Hello, I’m new here (I don’t speak English either) so I was making a game on my computer and yesterday it stopped showing the preview, I searched several times and didn’t find anything that explained how to solve the problem I saw on the console, I need help because I don’t know what it is and how to fix it.

The messages are these:

  1. Error caught while launching preview, this should never happen. RangeError: Maximum call stack size console.js: 35 exceeded

  2. Devtools failed to load source map: could not parse content for (path to Gdevelop folder) Unexpected end of JSON Input.

  3. The page or script is accessing at least one of navigator.userAgent, navigator.appVersion, and navigator.platform. Starting in Chrome 101, the amount of information available in the User Agent string will be reduced.

Update: I solved the preview problem, I went back to Gdevelop version 5.1.147 and edited my old version of the project, so reduce the events in several scenes, now the preview is working.

Hi Max, were you editing the game and the preview stopped? The only time this happened to me I was trying to put a javascript code in following a tutorial and then gdevelop had no idea what I was talking about because I had no idea what I was talking about and I got a black screen as a preview. I took the code out and it went away. But if you weren’t editing it I don’t know what it can be.

It was working normally, I was testing how the movements from top to bottom worked, and everything was going perfectly, then I just added more events and went to run the preview, now it just doesn’t open at all, I already changed Gdevelop to an old version , I even used an old version of my game that worked perfectly and it’s not opening either. I think it must have something to do with the java code.

Keep in mind if you are trying to input java code it will not work.

Gdevelop does not suppoet Java. It supports JavaScript. These are completely different and unrelated languages.

If you meant JavaScript, I would recommend disabling any javascript events and then try running the preview again. If that works you wi need to debug your javascript

To clarify: JavaScript is available for game logic but you are expected to be a full stack javascript developer, or at least an intermediate at JS. GD5 is designed with the event system as its first class game logic language, and if you are new to JS I wouldn’t recommend trying to use the engine to learn it, as you won’t find the same level of community knowledge nor support here.

I didn’t enter any code or anything outside of Gdevelop, I was using it fine until the preview didn’t work anymore, I was using version 5.1.147 of Gdevelop, so I updated to the latest (version 5.1.149) and my project the preview didn’t work anymore, even going back to version 5.1.147 it didn’t work anymore, I even used an old version of my project in the current version and without success. making it clear again that I didn’t change anything outside the Engine.

No worries, I’m just adding clarification since you mentioned java.

If you went back to a previous version and it still won’t load, it is unfortunately unrelated to the engine version, and likely something has changed with your event logic or your project file that is causing it. The call stack size error normally means some logic in your events is causing an infinite loop, something like a while event or repeat event that never ends, or other events that refer back to themselves infinitely.

Because I can’t know what it is i checked several events and they are all so that it works without a loop, even after this visualization problem, Gdevelop started to say in the message on the console that files are missing that I don’t even use in the project anymore, besides to say that I’m missing a folder called “Arial” in my project, and I never included or needed a folder like that, I think there was some madness between Gdevelop and my project.

Arial sounds like a font. One time I changed the names of some of my sprites in the folder and and they wouldn’t show up until I changed them in project. Did you change any names?

I changed the name of the characters in the game images and also in the project, but Gdevelop thinks that if I include a file or folder called “Arial” in my project, if I create a folder with that name in the project folder the message disappears, but my only problem is that the preview is not working.

“I created a new test project and it is working normally.”

Problem is solved, information in the post.