Glitch encountered with Piskel

We need more details about the issue. Ideally, necessary steps to reproduce the issue on our side.

I know this topic is old but its the only one about this bug, so, I have some info on it. Right before it happened to me my Piskel froze. No buttons in the GUI would work. I could still make the sprite, but couldn’t change my tool, which, at the time, was the fill bucket. Instead of filling, though, the fill bucket only colored the one pixel, not all of that color. Then the whole sprite froze. I assumed if I closed piskel and opened the editor back up it would be fine, but then I encountered this. As stated above this happens on all projects, so I can’t edit sprites in GDevelop anymore.

1 Like

Have you tried un-/re-installing GDevelop?

I’m having the same problem, i uninstalled gdevolop and reinstalled and still have same propblem!

GDevelop cannot be sync with a Onedrive folder.
Especially because the writing right is blocked on this synced folders and GDevelop can’t create a texture and save it in this folder, that’s why Piskel is buggy.
And a onedrive folder can also cause problem for GDevelop, and the audio editor JFXR bundled in GD5, and Yarn the text dialogue editor in GD.

Sorry to bring up this old thread but its the only one I found regarding this issue. I recently got the same Piskel glitch thing, did anyone find a solution?


Hi and welcome here :slight_smile:
Please confirm you’re running the latest version of GDevelop, and share a screenshot.

Hello! Look, I m using the latest version, but have this problem too!

P.S. This is two screenshots, i was pase updates screen on free space of Piskel editor because I can add only one media file here.

Thanks for the screenshot. Can you confirm that the problem occurs too with example projects, and the problem persists after uninstall/reinstall?

Yes! I reinstalled GDevelop but problem is persists:(

Please confirm if the issue occurs with example projects or only with your own personal projects.

with example “Platformer” too

hello, im replying at this because i’ve had the same problem: i get into an object, i edit it, i choose a color and pick the bucket, it only colours a tile, that’s weird so i close the editor and open it again, the page is changed (it looks like the images here), i close the page, restart the pc, check if im in the latest update (i am). Then someting weird happens: i go to a different game and choose an empty scene, i create a new object, i go to edit and it actually works fine. then im like “thank god, im going to edit the thing i was editing” and i have the same error again.

Thanks for the report.
We are having problems reproducing the issue on our side to investigate.
Are you using OneDrive or another similar cloud-hosting to store your projects?

I also encountered a glitch. i tried to reload and shut of my device but nothing worked

i have no clue what’s happening here

Hi and welcome here!
Are you using the standalone Piskel? This topic is for users experiencing trouble with Piskel within GDevelop, as shown in the title bar of previous screenshots:
Either way, we cannot help if you do not provide additional details.

This is a good sign if even the standalone Piskel version have this bug, It means it’s not on the GDevelop side. I wonder if Piskel is aware of this bug.