Half of my textures won't work

I was working on a pretty big game a couple months ago and it was going great until half of the textures i was using deleted. For example i had a tuxtures for a star and now it doesn’t work and it like it got deleted. I don’t know what happend but i wouold really like to be able to finnish the game.

Go into the resources and try locating the files, you can also check to see if the file paths are broken (files are no longer where they used to be)


1 Like

thansk for replying
i tried what you sugested but it doesnt seem to work
also, when i open the little menu (like on the second screenshot) there isnt all the options (its in french but you can still see that some options are missing)
i also tried to un-check the little ‘‘toujours garder en memoire’’ box on some missing textures and it didnt change anything
so yeah, thanks for helping : )

Have you changed the name of the folder that contained the images or the names of those images? Have you moved the folder that contained those images? These two situations can cause GDevelop to lose access to the images. When you upload an image, the path to access that image is saved (with the location where it is located, the name(s) of the folder(s) to access the image, and the name of that image). If you later modify the position or name of the files (like the cases mentioned above), you have to reload each image in each object since an access path that is no longer valid for these files would be maintained. I don’t know of any way to generate these new access paths in an automated way. If your case is one of these and you remember the names or location of the folder(s), you can return the folder to the position it was before or rename it as it was previously called (this way, the previous access path will be valid again).
Is your case any of these mentioned?