Hi! I am getting a Error whenever I try to open my project

I started using gdevelop for the past three weeks and developed a game. Today when i tried to open the file, I was getting a error as “Unable to open this project. Check that the path/URL is correct, that you selected a file that is a game file created with Gdevelop and that is was not removed”. Even a hour back i was working on it and saved it. Also when i tried opening it in notepad++ its showing empty and also the size of the file is showing as 0kb now. I remember it was around 7mb when i noticed it last time before the error…Kindly help!!!

Hi! I had this game stored in a separate folder in my PC with all the other objects (Png files). So the folder im talking about has only one Json file … and thats my game file… so i couldnt relate to what you are talking about… Unfortunately i didnt saved or kept any backup of the file… and i dont know why its showing as 0KB all of a sudden…

The file is called game .json.autosave
It should be in the same folder as your json file.
If you find it, copy-paste it somewhere before removing the “.autosave” and trying to open it with GDevelop.

This bug is a not yet well know, can you tell us if you use an SSD or HDD ?
If you have pressed multiple times the button save with the mouse, or with the shortcut CTRL+S.
If yes, how many times?

Hi! Yes i remember pressing ctrl+s like 2 or 3 times to save the file… and its HDD.