How i can fix this resources bar issue

Hey i have this issue with the resources bar, as you can see in the video under there, the bar doesn’t works as i expected, what i wanted to achieve was to remove only the inner fill from the bar gradually leaving only the black triangles, I wanted to achieve this with the continuous bar and not the separated unit bar

Tried to achieve the result using separated units and feels better but for some strange reason the bar is messed up in the game while in the editor is ok, why this happen

After all these hours i didn’t find a single reason for this behavior :sob::sob::sob:

Is it the motion or the visual quality? The messed up image is probably the smoothing. Is the smoothing option checked for the image? Try unchecking it.

If you are referring to the video is the motion, but i fixed it changing the resources bar with the one with separated units and i think is better, but for some reason the fill just doesn’t center with the background

I’m not sure what you mean.

The resource bar has a lot of settings. I would compare yours to one of the other bars with the default settings.

I tried, but not much has changed, also because as I said above if you see it in the editor it’s fine, while in game it’s wrong

Can you post a screenshot of your slider object settings? I know it’s lengthy. Maybe, one of the settings isn’t right.

I’m not sure how accurate previews for custom objects are. It may look one way in the editor and another way in preview.

I can’t say I fully understand resource bars but…
If the width is 660 and there’s 100 units then the unit width seems to be 6.6 not 6
(660 / 100 = 6.6)

If this is the issue i probably will end like this

Resource bars don’t seem to be forgiving. Honestly, I think it’s a bug or incomplete. It should be more responsive even if you use the wrong number. There should be more checks and balances. Plan for the unexpected.

The other style seems to be more versatile or at least a little more adjustable. Although, I still don’t understand the settings. The behavior does some of the math but the way custom controls are designed, you can’t hide texture settings that aren’t needed. It’s a bit confusing to me.

You was right, the 6.6 was the issue, thanks for your support :heart:

1 Like