Issue with music not playing

Hey all. I’ve encountered another issue with making my game.
Sound design is one of my favourite elements of a creation process, nothing satisfies me more. So here I am with a level, and all the sounds work perfectly- except the music. I don’t know the issue.

It’s just the standard “play it at the start of the scene” affair- but with a twist. See, I thought it was the issue where you have to interact with the game first to get it to play. I set up a dummy scene- nothing.

Then I thought of making it play once a timer has reached 0.5 second- nothing.

So I tried another piece of music…and it works perfectly. It also works perfectly with sound effects. Just not the music I made for the game.

And it’s not just the file that’s the problem- I tried another one I made and that one doesn’t work either. And believe me, these are just normal WAV music files that play anywhere. My sound effects made with the same programs work fine. I tried an MP3 conversion and those ones don’t work either.

I’m thinking it might be due to the fact they’re 2 minutes in length (and a few seconds)? I’ve tried them in OGG format too to see if it’s memory related (which reduces the track from around 20mb to 4mb) and that has the same result-nothing.

Update: I shortened the music to 1:15 from 2:00 and it works now. The only problem is it sounds terrible, because it’s meant to be a slow, driving song. But now I know that the issue is the song length.

Could someone test to see if they have a problem like this? where a song over 2 minutes won’t play? I really would like to circumvent this and be able to play my song at normal speed.

My issue is that my music only works on some devices but not on others. I think it has to do with the version of android

1 Like