Latest update cause player and camera jittering?

hello I updated gdevelop 5.0.130 and now player is constantly jittering and the camera layers have jittering at the start. I have no idea why is happening but started right after the update?

example at start camera jittering and player
Animation

camera events

I’ve seen this with my game as well; I rolled back to the previous version and confirmed the issue went away. The player character jitters rapidly when moving. My camera events:

I am using the Linux AppImage as well.

:open_mouth: ok thanks. how do I go back to the previous version?

I went to the releases page on github, and downloaded the 5.0.128 release there. Here’s a link directly to it: Releases · 4ian/GDevelop · GitHub
I’m not sure how smooth the rollback will be for platforms other than Linux, which was just downloading and running the AppImage, but Windows or Mac may have a different process. Before doing anything I’d make sure your projects are backed up.

1 Like

Thank you for reporting this.

The jittering happens when:

  • the “round pixel for rendering” is checked
  • the followed object center dimensions are even

While this issue is being fixed, this workaround can be used:

  • Define a custom center with a “0,5” decimal part (for instance: x = 24,5 and y= 24,5).
  • Disable the “anticipation” parameter of the camera following
3 Likes

great. it works now normally again, after i have unchecked the “round pixel for rendering”

1 Like

In the next release, following a sprite with even dimensions should no longer cause any issue (but odd dimensions will).

2 Likes

I am experiencing jittering with “round pixel to render”, has this been fixed yet?

The sprite that the camera follows is 68x68 pixels, my english is bad, the sprite is even, isn’t it?

The background looks deformed eventually, scale changed?, if I deactivate “round pixel to render”, so I think I have to deal with it activated.

It should be fixed. Share your project if your want, I can take a look.

1 Like

https://drive.google.com/file/d/1oTBU8i4NwmLdjxhmhyH1ba02_rONvPzj/view?usp=sharing

This is a simple example to show the jittering, thank you :slight_smile:

It still fails, since users cannot do a workaround, I consider it a vital priority to fix this bug ,thanks a lot :slight_smile:

Sorry, I missed the notification for your previous message.

It seems that the jittering appears when the screen width is not divisible by your game width.
This mode can be used to ensure the screen width stays the one you chose:
image

1 Like

Still happens :frowning:

I want to say that my problem is not jittering at all, I mean the jittering only appears when pixel perfect is selected. However if pixel perfect is disabled the problem is instead a visual glitch of stretching(stretched rectangular pixels) if pixel perfect is disabled, the project shared in my previous message shows it.

I am sorry but the reason it doesn’t work is because i am using lerp() to motion the camera when the player character is offset of the camera center like this:

lerp( CameraCenterX("",0), JugadorMascaraPlataformas.PointX(“Center”), Variable(velocidadCamara))

I wonder if I can modify it to works without jittering (using pixel perfect and no changes to the game size)…

https://drive.google.com/file/d/1FkKoJIdArxlm6QaTkkSLYkj8DUE9TZi_/view?usp=sharing

please take a look to this example that shows lerp() with jittering, how can I fix it?

This example uses big pixels and a smooth camera following:
https://editor.gdevelop.io/?project=example://platformer-with-tilemap

1 Like

sorry but I don´t want a bunch of extensions to fix something like a line of code

The 1rst event of this example reduce the effect of the issue.

image

1 Like

You can always add another Sprite as a Camera tracker then center the camera on that sprite and add lerp of 0.09 or 0.1 second
I use this unofficial extension I made by myself https://drive.google.com/file/d/11Ti6w5JMC5B_Papeoyahl9ZQKkSwBPIS/view?usp=sharing
and this events

2 Likes

it doesn’t matter what object is followed, the jittering still is present. I undestand your extension doesn’t do anything to remove the jittering, thanks anyway for your attetion :slight_smile:

I don’t understand what exactly the pixel perfect motion extension does.