Odd issue with multiple command calls of Dialogue Tree Extension

Short description:
Anyone ever tried to run multiple command calls inside Yarn editor? I am experiencing inconsistency when having more than 1 calls - call 3 times and only 1 or 2 calls went through.

Detailed description:
Trying to set up so that after a NPC conversation, it will trigger new quest item assignments (e.g. NPC X: "please find item A, B and C)
I have this set up in the yarn editor:


and here is the events to handle it:

(the shaded line is a debug line added to add the item to a scene array variable)

If I have 3 command call in yarn, there should be 3 items added.
but I’ve been getting inconsistency results, sometimes only 1 added, sometimes 2, never all 3.

Related screenshots

the events handling code is wrapped inside the top level code that handles the dialogue extension. provided here just in case.

Hi heta13. You’re a more advanced user than me and I haven’t tried doing what you’re doing, but I thought it might be helpful to say that I use three command calls in a row in the game I’m working on and all work as expected. Multiple command calls in a row should be okay, though mine are much simpler than yours and I haven’t created command events that have sub events or anything particularly dynamic.

image

All my commands are unique: I’m not trying to run the same one twice with different parameters. If I was troubleshooting, I think I’d see what happens if all three commands were unique by making a few dummy versions of your mission_item_assign command with different names and setting up a unique event for each. It’s repetitive, but it might reveal another Yarn quirk.

1 Like

thank you @worriedpixels - I appreciate the validation! I was worrying that I must have missed something obvious…

I solved this by working around the issue, creating my own function. It’s working consistently now! Cheers!

1 Like

another day, another Yarn quirk I found… :slight_smile:
apparently, a command call won’t work when nested inside a condition… like this:
Screenshot 2023-09-14 135706

everything gets executed, except for that command line (“mission_item_remove”)…

Just thought to post here in case anybody is trying to do the same…

1 Like