Paint effect problem (CLOSED)

So, In my game, there’s a paint effect object that does transitional effects.

It does it for when you go into a new scene (forward for exiting, backward for entering)

Same thing for going into battle scenes.

Now here’s the problem:

When you go back to the previous scene, it’s supposed to do the backward paint effect like at the start of a new scene.

But it’s not working! The scene resumes like normal, but the paint effect doesn’t happen!

starting a new scene (this one works)

Resuming the scene after battle. (DOSEN’T work)

How do I fix the resuming transition?

Have you tried another action to confirm that the condition acts as expected?
Have you tried another condition to confirm that the action acts as expected?

I tried adding other conditions and actions, but nothing seems to work.

Do you have any other ideas?

If “nothing works”, there is nothing to do except reinstall GDevelop and/or restart your computer.

How will that fix it??

You’re saying that nothing works.
If nothing works, there’s nothing to try except reinstall/reboot.
So unless you give us details on what works and what doesn’t, we can’t help.

I (kinda) made a work around. thanks for your help though! :slight_smile:

@takratzer, would you mind sharing your work-around, so there’s a solution available for others who may experience the same issue?

Well, I just changed it to “flash”, and didn’t do a transition effect for the resumed scene. It dosen’t really solve the problem, but it’s all I got. :man_shrugging:

I should have clarified that instead of saying I found a workaround. :sweat:

I apologize for the confusion caused on my behalf.