Pausing particle emitter

I read somewhere in the forums (posted by 4ian in '14) that setting the flow of a particle emitter to 0 is the cleanest solution, but for some reason it’s not working in the latest gdevelop. Is there something else that needs to be done? I just want to toggle particles on and off by pressing a key, but do not want to chance transparency as the emitter will be moving around the screen and that would show a trail on the screen from before you pressed the key.

1 Like

I’m not sure you should rely on old technical information like that, because the latest GDevelop (5) is very different from the previous version (4).
I’m not a particle user yet, but if you want to hide something immediately (no trail?), can’t you use the “hide” actions?
What do you mean by “it’s not working”?

1 Like

After playing with it, I found something interesting. if I change the beginning and end transparency to 0 at beginning of scene, and while holding shift toggle the first transparency to 255, everything works as expected. the trails left by the emitter seem to work “individually”: hold shift, trail is created, release shift, emitter stops, trail fades out, press shift again, emitter restarts, and I can 'start" a new trail without interfering with the previous trail. As in, when I release shift, the previously created trails fade out on their own due time.

However, if I have the end transparency set to anything other than 0, when I press shift, if the emitter has been moving around the screen, instead of “starting” to release particles (IE, turn on flow) it just changes the opacity so that all particles can be visible, even the ones that were created before I pressed shift. Letting go of shift immediately hides all particles, instead of them fading out.

TL;DR: setting opacities to 0,0 and toggling the starting opacity to 255 works as setting flow from 0 to would, unless the end opacity is non-zero, in which case it works as if the emitter were constantly releasing particles but there was a hiding mask over all particles, and setting starting opacity to 255 removes the mask to show all particles.

I hope some of that made sense, haha! :sweat_smile:

1 Like

Had the same problem. This helped me. Thank you!