PeerServer started - but no ID generated

Hi all,

I am trying to create a quiz-based multiplayer app.
I have been following Gemdev’s video ( How to Create an Online Multiplayer Game in GDevelop 5 : Peer-to-Peer! [Easiest Way]) as much as I can.

However, when I activate a local server, no ID is generated for me.

As a new user I am only allowed to upload one piece of media, so I have combined my screenshots:

  1. The peerserver appears to be active as it should
  2. External event “P2P” with information corresponding to the local peerserver
  3. P2P external event linked to (start of) lobby scene, as Gemdev shows it in the video
  4. Create Scene
  5. Create Scene Events
  6. If I preview, no ID is generated.

I have been trying for three days on two different computers and can’t seem to figure it out.

Does anybody know what I am doing wrong or what I am missing?


I haven’t used p2p in years now but can you try displaying the error?

Try this and let me know what the error is.


Thank you for your reply.

So, this is what I did:

I added the action to display the error where you put the error message in your video as well.

When I then give it a go, it just disappears, and in that place nothing is displayed, exactly what happens to where the ID should be displayed as well.

Oh, I’m not sure what the issue is, You can try downloading this free template and see if it works here.

Also, can you try the default server, your device needs to be connected to the internet.

i just tried it with the default server and it returned an ID

Thank you again for your help.

I tried the default server, with the same result - no result.

I then tried your demo project and it worked, with the default server as well as the local server.

That means, there has to be something in my project and I’m now trying to figure out any differences. My project has some scenes before a server connection is necessary, however all the events merely lead to other scenes or are answers to tutorial questions.

One difference though is that I am using the panelspritebutton extension and you’re not using it. Could that possibly have an impact? However, I guess other people would have picked up on this as well.

I did a bit more trial and error.

I created a very simple project with just one scene. If I enter the event “connect to broker server” on the scene without setting up an external event, the ID text is not changed to a generated ID (once again it just disappears), however on the screen (windows button + r), I get a message that a client has been connected with an ID there.

However, if I create an external p2p event where I add the event “connect to broker server” there, again, no ID is generated and also no message that a client has been connected.

Apologies for another message.

In my original project, I deleted the external p2p-event and once again added the event “connect to the broker server” in the event sheet for the lobby scene.

It has now generated an ID.

I’m not sure what the problem could be, I tried an external event and it still works.

For now I’ll continue in the way that generates an ID. We’ll see where this path takes me…

1 Like