Pixel art blurring

I don’t know if that’s the case, my game blurs the image, which has never happened before.

Don’t know what Round Pixel while Rendering but looks useful for pixel art games. Does turning it on Fix the problem? And are you positioning sprites in a decimal and not integers?

Round pixel during rendering, it’s only been useful to me for an 8x8 game I’ve been making. As Ulises commented, Round pixel rendering creates a lot of waves and distorts objects a lot at certain points.Maybe there’s a rule for using it.

And check this too please.

I do not understand, sorry!

I mean, how are you positioning the sprites and objects? Are they in decimal/points? For example: 15.5 or 20.3
Or are you positioning them in integers? For example: just 15 instead of 15.5 or 20.

They keep moving, so there’s no way I can tell you. But initially I always leave it in integer numbers, because I use the grid.

The fact is, I never had a problem with it, my resolution was always the same, and objects were always placed at any location/point.

Is it a 9 Patch that you are using for Platforms?
You might wanna look into this too.

No, I use an object!

Found the BUG or error. It seems that now if I use a set internal resolution, as I do 352x192 the pixels are blurry, but if I use 3.5 (or higher) zoom which is the same thing (practically), it’s normal!

That is, if I put the resolution as in the image:

It doesn’t work anymore. I have to go back to using the camera’s zoom. The fact that I use the internal resolution (352x192) is because the base size of my rooms has these dimensions, it’s easier to keep a default of 16x16 pixels.

I still don’t know if this is a BUG or not. But that really didn’t happen before.

Are you testing in preview or export? Preview isn’t going to be a true 1:1 comparison to export full screen due to how it deals with the title bar.

Edit: oh wait. If your internal resolution is 352x192, it should have never have worked. That isn’t an integer scale resolution to 1080p. It should have always had some subpixel rendering.

I’m testing it in preview only, but always in full screen. Not if you make a difference.
I know it’s not a full format for 1080p. But rendering should work. However, even testing resolutions that scale to 1080p the same thing happens!

Preview fullscreen may be weird for that same reason.

I can’t give you a definite answer other than regardless of what you saw before, 192 height res should never had appeared correct, and should have always had subpixel rendering/distortion due to incorrect scaling.

I would definitely try a native resolution of 384x216 and do a full export to see how it ends up. I’ve tried 640x360 as recently as this weekend with my main project and I’m not getting any distortion.

Also ensure you dont have round coordinates enabled on the object behavior properties for any platformer character objects you have. Thats being removed for the project level setting. And there could be some weird conflicts.

What I find strange is that, because only the objects I resize (32x32 I leave to 16x16) do this and the others don’t. Because, if it was really the resolution’s fault, wouldn’t I have to get all my objects and sprites distorted?

However I will look for a resolution that adapts correctly to the size of my tiles.

Hmm. I might have misunderstood.

Are you resizing the assets, or the objects?

In green the original size, red is resized

I would think that it should have always had distortion as well, as you are trying to merge pixels when shrinking, which usually is never clean. I’ll see if I can test some later this evening.

You might try saving a copy of your project in another folder, downloading an older version from the github and opening it up in that version to see if it has the same behavior. You can extract the installer using 7zip, and it contains an app64.zip in it that has the app. So you dont have to install over your current version.

I’m going to do the tests to compare, because I don’t remember this happening before, and look, I’ve done it many times! But, you can let me report here!

1 Like

@Silver-Streak I went back to the older version and the same thing happens. But look how interesting. If you set the resolution 256x144 which is compatible with 16:9 and 1080 it happens the same thing, but if you remove this line and put a zoom of 7.5, which is the same value, the pixels are perfect… Why?

Because it’s not (quite) the same thing.

You aren’t stretching pixels when zooming by 7.5

You’re zooming the assets by 7.5. There’s still room in the canvas for additional visual space, so the pixels are staying square. The canvas is 1080p regardless and isn’t having to adjust.

When you set the internal resolution lower and then scale up, it’s forcing the canvas to be 144 pixels high, then just stretching it to fit the new canvas size, which isn’t an integer ratio and having to stretch.