Please help me in correcting the problem-

com-gif-maker%20(1)
Hi everyone ,
see here the enemy to which I call as spider is not performing up to the expectations …(Not working smoothly and properly)


Here are my events :point_up_2:t2:
Can someone tell where is the problem and how can I fix it.
Thank you !
Don’t see the platform that was just for a trial … :sweat_smile:

The 1000 instant force is insanely high value, your applying a 1000 for in Y so the Crab thing is pulled down instantly. try a lower value or 0 and just move the thing in an horizontal plane.

What does moving a thing in horizontal plane means means ? @UlisesFreitas

Using 0 and trying a lower value is also not working!

I mean only move instantly in X axis.
Other way i to remove the separate two objects and only apply force.

No , it’s not working at all! What should I do?

I think the problem is here-


here the frames of walk animation are smaller than attack animation due to it’s hands attacking
I am not sure about it at all , I am just asking , is this so…

1 Like

All frames of all sprites for an object have to be the same size, otherwise your origin, center, and hitboxes will not align, causing bizarre behavior.

You can either increase all sprite frames to be the same size as the largest frame (with blank space) and assure the assets are aligned, or you will need to meticiously update every single origin and center point for every animation frame on the object, and even then it may not behave properly.

ok. I will try to increase all sprite frames to be the same size as the largest frame (with blank space) and assure the assets are aligned
and then discuss it here if it works or not…
:slightly_smiling_face:

I have done what u said @Silver-Streak but there are some things which can be fixed…
com-gif-maker%20(4)
Did u fell like something is not right or missing?
Although it’s working better than before but still…