Point inside condition acting on false instances

Hello everyone, I’m using a point inside condition to change the direction of an instance in the game. But the error is when instance1’s point is inside the appropriate object instance1 changes direction but instance2 does change it’s direction too even though its point isn’t inside the appropriate object. I can use the default platformer example for solution but I’m wondering if there is an error or not. I would be happy if you help me understand this issue :slight_smile:

The point inside … condition is testing the ground and wall not the skeletons. So, the only picking being done is of the wall or ground that the point is inside. Without a condition to pick one of the skeleton objects I think it’s using the 1st created instance (I’m not positive about that part) Since there’s no skeleton condition, the variable of all objects is being set to the same value.

If you add a for each object skeleton… and make all of the events a child of it then the condition will only apply to 1 instance at a time.

If I was at my PC I’d test the idea of it being the 1st created object being used by adding and deleting intances through events. Hopefully, someone with knowledge of the inner workings can add better context than me.


Thank you very much Keith_1357, for each object event solved the issue :slight_smile: I think I tried that before but there was a mistake then :slight_smile: Issue is solved.

1 Like