Rescan and Reload assets don't work as expected in Resource Tab

How do I…
I am trying to reload/relink my assets: I have thankfully backup my game from my usual laptop, and am using a different computer to work on it. When I tried opening up my game on a new computer, I saw that my assets where unlinked inside the Resource tab.

I then checked my game folder, and I noticed that all the assets that I had placed in a “asset” folder that I created inside the original game folder did not work, but all the assets in the game folder itself worked just fine.

What is the expected result

I want to be able to scan my assets successfully and have them relink when I scan or try to locate then

What is the actual result

So to try and solve this, I took all of my assets out of the “Assets” folder I had created, and put everything in the game folder.

I tried to re-open, re-scanning. locate my assets in the Resource tab, but nothing happens, not even a pop-up message. I want to try and avoid having to manually relink each asset (50+), since I cannot use my laptop.

Related screenshots

  • One image shows my original game file where I had created an “Assets” folder inside the game file. Here, only the assets NOT in my assets file show in the game
  • A second image shows that I have removed the asset folder, and have placed everything in the main game folder
  • A third image shows that my assets are still unlinked in my game, and the only assets that register are the ones that were originally in the game folder.

Screen Shot 2023-05-10 at 11.19.11 AM

To clarify, the scan directory/scanning for asset option doesn’t have any sort of re-linking functionality for existing assets. Scanning for assets just searches your directory for any files not already in resources, and adds them to resources.

This means it will not update/modify existing resource entries. The only way to update existing resources to a new location is going through each resource entry and choosing the edit option on the left panel, then click “Choose a file”.

Yeah, I figured that it (nooooo :face_with_spiral_eyes:), but just wanted to make sure.


1 Like

So I just tried to update my asset resources as I’d usually do (Resource tab > choose file > select file). I remember this method working on my laptop, but while I’m able to locate the new files, the game is still seeing those files as unable to load/unlinked?

But I noticed that with the files I’ve tried to re-link and I go to the Piskel editor, I can see the file and edit it as normal. But when I edit and save the Piskel edit, the file still wont load/show properly.

All my assets are now in the main game folder, but I’m still not able to re-link them or have them load/update properly. I wonder if it has something to do with me using an HP laptop at first, but now having to use a Mac computer now. Is it a compatibility issue?

And I just tried creating a sprite object from scratch and adding an image as normal, but that image asset is showing up as a broken link, even though I can see the file on my game folder…?

UPDATE: Turns out even if I open a practice project, the computer I’m using (a Mac desktop), is showing invalid paths and none of the assets are showing up in the editor or resource tab. But when I preview the game, the game looks as normal.

At this point, I haven’t the faintest idea as to what is wrong…

I just remembered the code inspector area, and it’s showing a bunch of errors with the invalid assets from my hard drive. I’m actually not sure what these all mean, or how to resolve it.
Screen Shot 2023-05-15 at 2.23.16 PM