Ribbon hidden

I am using gd for months now and it never gave me any problems. However, two days back I opened game develop and realized that the ribbon had just disappeared. I tried everything. I uninstalled and reinstalled it. I also used a special software (iobit uninstaller if you must know) so that if there are any configuration files they will be removed as well. However, none of that worked.

Delete {Your user folder}/.Game Develop/options.cfg :slight_smile:

I did search the forum for the word ribbon and I think I came across this but then I think either I did not notice the “.” or it wasn’t there at all. I did not know what did {your user folder} mean but I knew where .GameDevelop was so I figured it out. Thanks a million, you saved my life :mrgreen:

{Your user folder} means /home/, e.g. /home/darkhog on Linux and c:\Users<yourusername>, e.g. c:\UsersDarkhog on Windows (in case of WinXP, it’s C:\Documents and Settings…).

Anyway, once GD source is made public, I’ll try to work on this bug. If all else fails, I’ll add “Fix ribbon” button that will forcefully bring ribbon back by its neck :wink:.

Yeah, but where do this button should be put?
Maybe another solution would be to add a “Reset preferences” link in the start page to erase the options.cfg file.

Why erase all option if only one that hides ribbon should be removed? I’ve played around a bit with options cfg and I know which setting proves to be problematic. Also this’d be “figurative” button - most likely either context menu option that shows on all menus or as you said, something on start screen.