Scene Tab malfunction

Greetings:

I download GDevelop from the website and I instaled the aplication in my Laptop (Dell Inspiron 1525), but it never worked well.

Everytime I open the Scene Tab, the tab freeze like this:

http://prntscr.com/5v2pvk

It doesn´t matter if I have another program opened, or if I have every single software down… It´s just don´t work.

I sent a email to compilgames@gmail.com, but I didn’t receive any answer…

I thought that maybe its something wrong with my laptop; but I joined the GDevApp and the Scene Tab in the web application works fine. I´ll post now the specifications of my laptop just in case you need it:

Operating System
MS Windows 7 Ultimate 64-bit SP1
CPU
Intel Pentium T2390 @ 1.86GHz 46 °C
Merom 65nm Tecnología
RAM
3,00 GB Dual-Channel DDR2 @ 265MHz (4-4-4-12)
Motherboard
Dell Inc. 0Y332G (Microprocessor) 47 °C
Graphics
S/M 900IFT (1280x1024@85Hz)
Mobile Intel(R) 965 Express Chipset Family
Mobile Intel(R) 965 Express Chipset Family
Hard Drives
156GB FUJITSU MHZ2160BH G2 ATA Device (SATA) 46 °C
Optical Drives
TSSTcorp DVD±RW TS-L632H ATA Device
Audio
SigmaTel High Definition Audio CODEC

Any solution for this problem?

Try to upgrade your graphics card driver and then relaunch GD. :slight_smile:

Thanks for your reply, 4ian (by the way, great proyect!). :wink:

Sadly, didn´t work. I already have the latest drivers in my notebook. But still trusted in your advice, and I re-downloaded and reinstalled the cream of the crop, the latest of the very latest of the graphic drivers for my GPU. Didn´t work. :neutral_face:

I ask to Intel itself the drivers, and they send me the same driver I already have. I uninstalled, errased, repaired the windows registry, restarted the laptop, reinstaled the latest drivers. Didn´t work. :frowning:

I try and investigate every single problem related with my GPU in diferent tech forums since your reply. Nothing work.

I don´t understand. Why the Scene Tab works fine in the GDevApp (web browser), but hangs out an crash in my GDevelop (Windows Installer) if the problem is caused by the drivers of my GPU (or my own GPU)? :confused:

If anny have a clue, please tell me. It´s a very sweet software and I´m still willing to use it, but I CAN´T :cry:

Other programs that use my GPU and works in this Laptop:

Adobe CS6
League of Legends
Gimp
LibreCad
Game Salad Creator
Inkscape
Blender
Google Web Designer
Hearthstone
Aptana 3

Best Regards!

Can you tell us what version of GPU drivers do you have?

//edit: Also you seem to have an antique computer. It’d be good if you could replace it unless you don’t have funds. Intel 965 is really old and crappy on-board graphics and have lots of compatibility issues, especially with OpenGL apps (Gdevelop is one of them). And Pentium is out of fashion for a long time.

I’m not sure, but from the new-style of some icons, the keyboard language, and the desktop shortcut in the taskbar, I think he is using a custom theme :slight_smile:

By the way, have you tried to deactivate that theme (if it’s a theme) ?

It’s the old Windows style on Windows 7 (not a custom theme)

I’ve referred more to his CPU (who uses Pentiums anymore?), RAM (3GB where standard is 4+GB) and the fact that he’s trying to run software clearly meant for stronger machine (Win7 itself for example) with at least Core processor.

Also Intel GPU, especially as old as he has will prove issues with apps using openGL, especially in ways OGL wasn’t meant to be used (2D OGL calls), like GDevelop.

And don’t say that LoL and Hearthstone works fine. Both games are so basic in terms of graphics that I bet porting it to really old version of DirectX, say DX8 wouldn’t be much of a problem. No sense in doing it obviously, but it wouldn’t pose much of an issue technically.

Thanks for the reply, everyone!

Yes, I had Windows 7, with all that aero aesthetics deactivated.

I really don´t know what youre trying to say…

“You have a crappy computer”; thats the technical problem? There´s no need to search any longer? So, yeah, it´s not a hell of a laptop I use. But still… I CAN work in the GDevApp (the web application) normaly.

In my crappy laptop, of course. It use OpenGL too, right? The drivers I use here are this:

https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=18232

So, If there is no other solution, more than change my little crappy laptop in order to use GDevelop (the windows instaled version). I guess thats it. I will not use it.

I will use other software, or use only the GDevApp (the web application, yes!), or GameSalad Creator. But I can´t afford to buy another computer (or GPU) just becouse a single tab in a program that have a workable web application don´t work as spected.

Sorry

Can you go in GD’s folder (C:\Program Files (x86) or Program Files\GDevelop) and start GDIDE_dev.exe. Then, teel us what is written in the console when you open a scene editor.

Of course, Viktor! Thanks you! :mrgreen:

I´ll do it right now! :smiley:

GDevelop IDE Launcher
Creating a dummy SFML object…
Opening GDIDE.dll…
Starting GDevelop…
GDevelop initialization started:

  • Config file set.
  • Language loaded
  • Single instance handling done
  • Image handlers loaded
  • Crash management ended
  • Splash Screen created
  • Displaying GDevelop version information :
    GDevelop 3.6.78.0, built 25/01/2015
  • Creating a useless SFML texture
  • Removing CppPlatform/Extensions/AStarAutomatism.xgdle
  • Loading platforms and extensions:
    Loading platform GDCpp.dll…
  • Setting up events compiler…
  • Loading events code compiler configuration
  • Loading builtin extensions… BuiltinObject, Sprite, BuiltinCommonInstructions
    , BuiltinCommonConversions, BuiltinVariables, BuiltinMouse, BuiltinKeyboard, Bui
    ltinJoystick, BuiltinScene, BuiltinTime, BuiltinMathematicalTools, BuiltinCamera
    , BuiltinAudio, BuiltinFile, BuiltinNetwork, BuiltinWindow, BuiltinStringInstruc
    tions, BuiltinAdvanced, BuiltinExternalLayouts, done.
    Loading of GDCpp.dll done.
    Registration in platform manager of GDCpp.dll done.
    Loading extensions for GDevelop C++ platform… AdvancedXML, AES, Box3DObject, C
    ommonDialogs, DestroyOutsideAutomatism, DraggableAutomatism, Function, Light, Li
    nkedObjects, Network, PanelSpriteObject, ParticleSystem, PathAutomatism, Pathfin
    dingAutomatism, PhysicsAutomatism, PlatformAutomatism, PrimitiveDrawing, SoundOb
    ject, TextEntryObject, TextObject, TiledSpriteObject, TileMapObject, TimedEvent,
    TopDownMovementAutomatism, done.
    Loading platform ./JsPlatform/GDJS.dll…
  • Loading builtin extensions… BuiltinObject, Sprite, BuiltinCommonInstructions
    , BuiltinCommonConversions, BuiltinVariables, BuiltinMouse, BuiltinKeyboard, Bui
    ltinJoystick, BuiltinScene, BuiltinTime, BuiltinMathematicalTools, BuiltinCamera
    , BuiltinAudio, BuiltinFile, BuiltinNetwork, BuiltinWindow, BuiltinStringInstruc
    tions, BuiltinAdvanced, BuiltinExternalLayouts, done.
    done.
    Loading of ./JsPlatform/GDJS.dll done.
    Registration in platform manager of ./JsPlatform/GDJS.dll done.
    Loading extensions for GDevelop JS platform… Unable to open Extensions (./JsPl
    atform/Extensions/) directory.
    Loading extensions for GDevelop JS platform… DestroyOutsideAutomatism, Draggab
    leAutomatism, LinkedObjects, PanelSpriteObject, PathfindingAutomatism, PhysicsAu
    tomatism, PlatformAutomatism, PrimitiveDrawing, TextEntryObject, TextObject, Til
    edSpriteObject, TopDownMovementAutomatism, done.
  • Platform and extensions loading ended.
  • Creating main window
  • Connecting shortcuts
  • Setting help provider
  • Loading events editor configuration
  • Connecting parameters editors
  • Creating log file (if activated)
  • Initializing platforms…
  • Starting web server…
  • Initialization ended.
    Asking for update info: compilgames.net/update/?p=GD&l=&v=3.6.78.0
    GDevelop on GitHub
    Try GDevApp, the online game creator based on GD
    github.com/4ian/GD
    gdevapp.com?utm_source=software … ign=launch
    Sending analytics data…done (201)
    Sending analytics data…done (201)

That´s all what the console says. The freeze happens when I touch this tab:

prntscr.com/62fk6l

But, as I said, the Scene Editor tab works great in the GDevApp:

prntscr.com/62fnuu

It uses OpenGL too, right? :confused:

GDevApp uses webgl (OpenGL) when your browser accept it (and it refuses it when using a non supported graphic card) or normal drawing instead. For GDevelop, it’s different, it’s based on SFML and need OpenGL (which is badly supported by Intel integrated chips).

I have no idea where the bug can come from (and if it’s related to GDevelop or to poor drivers).

Hummm… Maybe we can do a test! :mrgreen:

There´s another program, videogame, or something that uses the same OpenGL that GDevelop?

I will try running it in my Laptop and see what happens. :wink:

By the way, WebGL and Normal drawing FTW! Any chance to have a option for GDevelop for use them in the future? :smiley:

For example, this game : http://en.sfml-dev.org/forums/index.php?topic=17276.msg51060

Noup! Didn´t work. He do the same freeze, like the GDevelop. :frowning:

Sad but true… :cry:

So, it’s not related to GDevelop but to your graphic card (and its drivers). :frowning:
I don’t think we can do anything about that. :frowning:

The Drivers says “OpenGL 2.0 included”
The GPU Caps Viewer report says “OpenGL 2.0”
But the official bulletin of Intel says “GM965 only supports OpenGL 1.5”

So I guess that GDevelop use OpenGL 2.1 or higher.

I read something about using MESA to emulate OpenGL in this GPU, but it´s more sure that I will not try it. :frowning:

Thanks Victor for the patience. I guess I´ll only use the GDevApp to the day when I buy a new PC, or GDevelop implement a new option to use webGL or normal drawing instead of OpenGL.

Hasta la vista, guys! :cry: