[Solved] Can't Launch or Install

My son is running Gdevelop on his Windows 10 laptop. Been running fine until a few weeks ago stopped launching. Uninstalled and tried to reinstall but the installer just gets stuck like in the picture.

Tried beta 88, 91, 92 and Windows Compatibility mode and run as Administrator. No luck.

Appreciate any help!


Did you try to “run as administrator” the setup ?

Also, you should try to delete all old files from previous installation in C:\Users*YourUserName\AppData\Roaming\GDevelop 5*
Sometime files here can be locked for weird reasons by Windows, avoiding the installation/update to work.

Last thing, after deleting files from user folder, you can try a windows registry cleanup with softwares like ccleaner or similar, then try to install again.

1 Like

Tried all of that with no luck. Still won’t reinstall.

Is there anything specific in CCleaner? Just used defaults.

Any other suggestions? Thank you!

Uninstall Gdevelop properly before a new install.
C:\Users\YOURUSERNAME\AppData\Local\Programs\gdevelop ← uninstall.exe is inside this folder.

And remove manually this folder (make a copy before if you need backup):

C:\Users\YOURUSERNAME\AppData\Roaming\GDevelop 5 ← all preferences and caches files.