[Solved] `complete clipped text scrolling` action not working

when I try to use the complete clipped text scrolling action in the dialogue tree it just freezes the text, while it worked normally in older versions. is it a bug or did they add a new action for it?

Can you post some screenshots of the corresponding events? I tried reading them from your gif, but it’s almost impossible.

This is what I use and it works perfectly:

Might be a bug or not, but nothing has changed on dialogue recently, to be sure please upload a project reproduction to be able to debug correctly.

1 Like


it randomly does work and doesn’t sometimes so try multiple times (this isn’t the only project that has this error)

here this one is responsible for the skip feature

First of all, variables cannot contain spaces. Also, your events need to be cleaned up, this is probably why it’s not working correctly.

When disabling the system that checks if the dialogue isn’t playing (you named it “ends”), then the skipping of lines works fine, so you have to look into that part.


Aside from everything else that’s wrong, doing this will make it work:

Move this timer condition.
Dialogue Timer Condition Location 1of2

To here.
Dialogue Timer Condition Location 2of2

To elaborate, the skipping worked fine. You were just not modifying the text object anymore because the “textscroll” timer had just been reset to 0.

it worked well now, thanks!