(Solved) Delete After Animation Doesn't Work. Help. Screen Capture

Hi, Im trying to delete the boss after an specific animation is finished but it’s not working.
I’ve tried making it a subevent, a separated event, adding and removing the specified number of the animation and still doesn’t work.
Anyone knows what could it be?

Edit: I want to add that If I change it to delete it when it’s playing animation number 1, it does delete it.
But I need it to play the animation first, I don’t want it to just dissapear like nothing.
I don’t understand what’s wrong.
The idea is make a boss fight in three stages, so after the first part it dissapears, and then I would make a Boss2 for second part, and Boss3 for third part, with different movements and actions.

Is the boss animation a loop animation?

Not the one that I’m setting before dissapearing.

Actually It also caught my attention than after changing to animation 1 it goes back to animation 0 but I have no event telling the game to do that.

Check your events to is for sure that some other event is set to get the boss back to animation 0 assuming this is boss 0 is the idle animation and boss animation 1 is boss dead anim.
Try adding Trigger Once in both events that you shared in the screenshot so you ensure that if the Blankey is in collision with BossFade only happens one time.
Other good practice is to add some Object variable to the Boss Sprite or BossGroup so you can control Boss actions with that variables.
For instance my boss has a variable like obj_var_is_alive = true

When my player kills the boss or in your case Blankey collides to BossFade set variable to false, then in other event check
If Boss variable obj_var_is_alive == false
And animation = 1
And animation finished
Action: Delete

Thanks, I’ll try that, but I’m starting to think that something is wrong with my Gdevelop.
I’ve got tired of trying to make the boss dissapear so I decided to do a different thing.
This first stage is a persecution scene, where the boss follows the player throwing fireballs.
So since I can’t make it dissapear, I thought ‘what the hell, I just move through a different stage through a door’. But that’s not working either. When my character collides with the door nothing happens.
It’s just too weird, I’ve done already an Intro and 3 other levels using collision with a door to change the stage, and t was easy and worked perfectly before… I can’t get it.

Well it turns out I just had to restart my PC. It wasn’t laggy or anything, so there where no signs of it working wrong, but I tryed it anyway and my problem was solved.
Sorry for all the trouble.