(Solved) Exporting game to android manually

Is this normal? I just stuck on this step, it just loop with Starting a Gradle Daemon

Try to reinstall Graddle and don’t forget to add to the Windows path

I don’t know if I did this right, but here’s what I did on my Windows path…

This is for an older version of Graddle but works take a look

1 Like

I followed the steps with latest version of Gradle but in the end my CLI or command prompt can
't recognized ‘gradle’ as an internal or external command. etc…

Should I downgrade my gradle, like on that example?

Which is your actual version of Gradle? so I can look up for documentation.

here’s my Gradle current version = gradle-6.4.1


Gradle runs on all major operating systems and requires only a Java JDK or JRE version 8 or higher to be installed. To check, run java -version :

$ java -version
java version "1.8.0_121"
Microsoft Windows users

Create a new directory C:\Gradle with File Explorer .

Open a second File Explorer window and go to the directory where the Gradle distribution was downloaded. Double-click the ZIP archive to expose the content. Drag the content folder gradle-6.4.1 to your newly created C:\Gradle folder.

Alternatively you can unpack the Gradle distribution ZIP into C:\Gradle using an archiver tool of your choice.

Step 3. Configure your system environment

Linux & MacOS users

Configure your PATH environment variable to include the bin directory of the unzipped distribution, e.g.:

 $ export PATH=$PATH:/opt/gradle/gradle-6.4.1/bin
Microsoft Windows users

In File Explorer right-click on the This PC (or Computer ) icon, then click Properties -> Advanced System Settings -> Environmental Variables .

Under System Variables select Path , then click Edit . Add an entry for C:\Gradle\gradle-6.4.1\bin . Click OK to save.

Step 4. Verify your installation

Open a console (or a Windows command prompt) and run gradle -v to run gradle and display the version, e.g.:

$ gradle -v

Gradle 6.4.1
1 Like

That’s what I did before, and this thread is the problem I encountered.

Lets start again with some basics.
After Install you reboot?
Check CMD → C:/>gradle -v is getting the correct version?
Is Java version 1.8.0_121?

gradle -v = Gradle 6.4.1
java -version = 1.8.0_251

I did restart my laptop after installation and I will try to restart again.

After restart, the error is gone and it build the apk but a new problem appear.

Maybe you already encountered this one or someone already encountered this…

Take a look here I think is about ANDROID_SDK need to be included as VAR PATH

1 Like

Alright, I finally fixed the problems… Thanks @UlisesFreitas for helping me out!

For those members who will export your game manually in the future…

What I did is…

If you encounter this error above on this thread,

Do this:

ANDROID_HOME is deprecated, ANDROID_SDK_ROOT is a new variable (recommended setting).

After that if you encounter another problem that says (white highlighted)

You should do this:

  1. cd /d “%ANDROID_SDK_ROOT%/tools/bin”
  2. sdkmanager --licenses
    and accept all licenses and agreement.
    Source: Accept agreement and licenses

Now you can build your apk manually using cordova.

I’m glad you fixed :muscle:

1 Like

Hi @UlisesFreitas, I finally exported my game as apk using cordova. When I copy the apk to my phone and install it, it says App not installed. I wonder what is the reason why I got this error message.

Hi @nmrisrl11, try a deep read of this
or this a lot of read I know look at 4.
I’m going to check if I find something else.
Maybe this helps too

Thanks, gonna read it and find a solution and update this thread.

Hi @UlisesFreitas, I installed it now but it keep saying that “Play Protect doesn’t recognize this app’s developer. Apps from unknown developers can sometimes be unsafe.” But anyways I still got it installed to my device now.

What I found is that I uninstalled my previous version of my apk installed on my phone, I used GDevelop’s Export project to a standalone game.

Look here maybe you need to complete that it’s only in English I guess