(SOLVED) GD doesn't rename objects in Linux

First of all thank you in advance for reading this post and any and all the help that the community can lend me.

Second I’m from México so you’ll excuse my bad English :blush:

Hi all, I’m new to Game Develop and Game Developing in general, been trying for 3 days now to get the begginers tutorial working but I must be doing something wrong since I can’t doit with neither the writen one or the videotutorial.

I’m working on Linux Mint 15

Here’s my list of doubts:

I’m supposed to rename my objects in the right window but even after doing so GD keeps refering to them as NewObject, NewObject1 and so on; this is I suspect the origin of the syntax error I get when trying to make the bullet object be created at the Tank/Turret’s possition, because when I leave the names alone it works to a point (Haven’t gone past making the Turret/Tank move).

My knowledge of programming is very limited hence my interest in a tool that could help me make my crazy idea of a game come true, I’m not adverse to paying for the software that I use but I like the idea of trying the software first, and I don’t like to rent a software I want to own it (At least the copy in my pc) so…

Could anybody please help me to get started with really easy, step-by-step, fool proff instructions?

Once again thank you in advance for your time!

Hi and welcome in the club :laughing:

I’m new to GameDevelop too and I don’t know a lot, so maybe I’m not the one who should give you any advice but why not. :sunglasses:

My first advice for you is that, If you experiencing any problem, difficulties try to replicate your problem in a short example project and attach It to you post, or upload to somewhere (I find google drive useful), and make a link in your post. Se we can have a look, test and find the problem easily and help you what need to be fixed and how. I think it important to replicate only that specific part of you project that cause the problem, because if you upload your full project file with hundreds line of events, it makes more difficult to find the problem. Just keep it short and get to the point in your example project (and don’t forget to use comments that helps too). The community very friendly and helpful, they going to help.

Regarding your present problem, I think GameDevelop had a glitch with renaming objects, it has been fixed in the new version, but I don’t know if it released yet. New version always comes to Windows first and only as a test version, if no problems found, it get ported to Linux and released on the main page as main download.
You can find the most recent test version here (Windows only):
But for now, I recommend to make a new project and make sure when you are creating an object, name it as you want right at the time as you create the object, don’t rename it. If something still don’t works, replicate only the problem in a small project and attach it to your post, or upload somewhere and we have a look.

For tutorial to get started, I think 4ians beginner tutorial is great to start:

If you follow the tutorial it should work, and teach you the basics if something still don’t works or you don’t understand something just come here and ask :slight_smile:

Thank you very much ddabrahim, for your advice and solution, I’m of to test it right now!

Edit: Tested ddabrahim’s solution… Sadly it doesn’t work since I can’t find anywhere in the object creating process where to name it, and editing the objects properties the name is not enabled to do so…

Well maybe I’ll have to start learning on windows since it looks like it is the most stable and recent version, only one question about it, can I develop for linux wile usign GD on Windows?

You can develop your game on Windows. If you want to compile it for Linux, you will have to open your project on Game Develop Linux.
(Except if you develop HTML5 “Web” games).

So for every platform I want to develop for I have to own a machine?

Too bad for the Mac community they’ll loose the chance to play my games! :unamused: :mrgreen:

When you create an object, you should be able to enter the name.

  1. right click in object editor
  2. select add an object
  3. select object type (sprite)
  4. press OK
  5. enter name
  6. press enter to create new object
  1. right click in object editor - Check
  2. select add an object - Check
  3. select object type (sprite) - Check
  4. press OK - Check
  5. enter name - Where? There’s no moment or place where GD asks me or lets me do that, Believe me I just spent 10 minutes in my current working “Installation” on linux and it just doesn’t want the objects renamed.
  6. press enter to create new object - Check

And even after the fact, I can “rename” it but internally GD keeps “thinking” of them as NewObject, NewObject1, etc.
I even checked if I needed to save the game, close GD and restart for the changes to take effect to no avail, I’ll just log out of linux and restart the machine on windows (Hope GD works ok on Windows 7)

Going trhough the forum posts I found out that some people in the forum using GD on linux seem to be able to rename the objects with varying grades of succes so… what is happening? did I download a different version? how can I know what version do I have? and how do I download the latest Linux version?

As always thanks in advance for your time and sugestions.

Gd works really well on Windows (it’s not the case of Linux).

The renaming issue is a Linux-related problem that will be fixed in the new version I’m going to release soon. :slight_smile:

Thanks, although it’s not my OS of choice I keep it around for cases just like this one (Even if they are more and more rare)

Many thanks for the acclaration and most of all for such a superb software development.

Bravo Maestro!

When you create a new object, before press enter, on the right side, in the object’s editor window, the name of the new object should be highlighted, so you can enter and create the object with a custom name.

Thanks for the graphical acclaration but currently it does not do that, when I press Ok the object is created and the window for doing so closed, afterwards all my problems arise (Or should I say arose?)

Anyway, it wont matter since 4ian said he will be releasing the new version today :smiley:

Now… How do I upgrade GD?

GD should show you a message when it’s launched to tell you there is a new version.
Just download and install it again from the website.

Downloaded, removed old from my desktop and extracted the new on the desktop, launched it and it just works!

It still doesn’t let me to name the object at creation time, but now I can rename it and GD recognizes the name as that of the object, no more NewObject’s ad nauseaum! :smiley:

Thanks again 4ian! (First game I sell you can expect a fat donation to the cause! Or earlier if I find myself with some extra cash!)

Marking the post as solved!