[Solved] Gdevelop error show some weird message when I close GD before the preview


I don’t know what happens here, but the point inside not working corectly, sometimes I move the condition higher or lower and it’s fixed. but it’s not right now and I’m really frustrated about that, I can’t even find what is wrong with my event, or maybe it’s the file, or Gdevelop software itself.

then I tried to close the Gdevelop and this message show up.
error

I don’t want to make a new project and start all from zero. I use the latest version of Gdevelop and no update was detected, is anyone have a solution about that error?

Can you explain by what you mean by this? How is it not working properly - what are you expecting and what does it do?

And which event are you referring to - there are 2 point inside conditions in the screen snip, which one do you mean?

both don’t work, I mean the “point inside object” condition doesn’t work correctly, but if I change the “point inside object” condition to “collision” it works.

It does work. I’ve just created a test project, exactly the same events as the two you posted, and it works perfectly.

If you have more than one bahantea object on the scene, then this will happen (assume bahantea is the purple triangle and the teapot is the green square):

image

bahantea B is inside the green square, so the first event is actioned. However, bahantea A is not in the teapot, and will action the second event on the same teapot.


but it doesn’t work in my game, I don’t know, I even created a new blank game and tried it, but it doesn’t work. I have 3 red and blue squares, I tried dragging the first and second red squares but it didn’t work to change the color of the big blue squares.


but if I drag the third red box, it manages to change the color of the big blue box.
I don’t know where I went wrong


I tried changing the condition to collision and it works perfectly. but it’s not what I expected because I need points to do my game.

You also changed the order of the events. Change the order of the events with the point inside condition.

On a side note, the JavaScript error you mention usually occurs when you close GDevelop without closing the preview first.

1 Like

As Gruk mention it, this happened only when you close GD before closing the preview.
This isn’t a related bug to the condition “point inside”.