(SOLVED) GDevelop Preview Black Screens when "dialogue is running" is in events

I was working on a game where I needed a dialogue system that only dialogue tree can do.
Here is the issue, for whatever reason, at some point, my game continued to black screen no matter what I edited in the events.
I come to find, and isolate, it was “dialogue is running”.
I debugged my game while I had “dialogue is running” and no frames where collected.
I uninstall GDevelop and reinstall to a the latest version, still black screens.
I uninstall GDevelop again and to a older version, still black screens.
I restart and update my laptop, still black screens.

I created a new project, no events, no objects, no nothing, and added “dialogue is running” as the sole event with no actions.
Black screens.
I debug this without conditions and it runs fine.
I debug this with “dialogue is running” and no frames, no nothing.

…Well, I check my older projects that contain a dialogue system. They are all fine. At this point, I am confused and not sure what to do. At some point something happened but I can’t tell you what.
Can someone help me with this?
I need a dialogue tree in my game. Otherwise, I can no longer use GDevelop and that is the last thing I want to do.

I can only reproduce this if I’ve not loaded a dialogue file. The condition is not designed to work without the actual dialogue system being loaded, so this doesn’t surprise me.

Make sure you have some event with the “Load dialogue data” action (preferably from json file) otherwise the dialogue system doesn’t load, and related events likely won’t either.

As an example, this loads fine (with the json file from one of the dialogue example projects. Completely new scene, no other events).

1 Like

You are right, interestingly enough I did have a file already loaded and it still black screened. However, after I spent some time away and accepted the defeat, I looked back at the conditions and re-added the dialogue data once you responded…, and it worked again.
I hate that it was that simple but I tried so many things (including reloading the file) while I had the game open but nothing had worked.
I guess it’s either my laptop was the issue or whatever happened. Still…, I appreciate you responding so soon. I need time to heal from this :sob:

1 Like