[Solved] I need help again

when my player is in collision with an npc while moving left or right, the player telelports erraticly

Can you add more details maybe a screen shot of the events where the 2 objects collide?

It sounds like conflicting behaviors or forces like a Pathfinder and seperate objects type of thing where one behavior or action is trying to push the player in one direction and another action or behavior is pushing it into another direction. The behavior usually wins.

Do you have actions that apply force or seperates objects? Any type of actions that attempts to move the player. It just sounds like there’s a conflict and something is pushing back.

i did not put a collision block on the npc

The only action I see that affects movement is the activate top down movement. Are you disabling it somewhere? I remember an issue with disabling and enabling.

If that is causing it then maybe this will help. If not then maybe we need to see other events that might move the player.

i dont disable top down movement

Then I’m stumped. Anyone else have any ideas ???

ask other people to help

though it probably has to do with dialogue functions

A more specific title might help like “player teleports when it collides” Something short and to the point. (click the pencil next to the title)

I don’t see any events that affect the players position. If there are any that apply a force or change the position or seperates or uses any behavior or action then it would be helpful if you posted a screenshot. We want to help but I don’t see anything that could causes teleporting.

Does the NPC move? Are you using seperate objects on either object? Are you using any other behaviors?

Use the mag icon at the top-right of the eventsheet and search for npc, take a screenshot of every action it finds.

Also specify the behaviors both the player and npc have, if any.

What about any behavior on the player and npc? (Other than top-down movement)

Also, can you try using “ignore default controls” instead of deactivating behavior?

umm how do i do it tho

A few things:

  1. What Keith mentioned is correct. You should be setting your movement speed to zero before disabling the top down behavior. You likely have movement built up that get reapplied after re-enabling the behavior.
  2. While potentially unrelated to your movement issue, there are objects in your event sheet have no sprite. They cannot be used correctly in events that deal with collision, movement, animation or other options
    It doesn’t matter if you want the first frame to be invisible or not, there has to be a sprite there. Even if the sprite is a fully transparent image.

Outside of the above, it seems your events are not your entire event sheet, so there’s not much I can gauge on the rest of your set up.

i remember that i disable movement upon starting a dialogue

Can you provide a preview link so we can test the bug and see what is happening

how do i do it, i am not making it on the website