(SOLVED!) Implement more than one cursor animation?

My goal: I have three cursor animations. The purple arrow in the default animation. The hand animation is the Take to Inventory animation. The red and blue animation is the Ability animation.

They are supposed to change when the cursor hovers over certain objects in the game. The hand animation is supposed to appear when its over an object the player can put in their inventory. The blue and red animation is supposed to appear when its over an object that the player can use the character’s special ability on.

My problem: With one exception, the animations don’t change when when the cursor hovers over other objects. I tried the Cursor Type behaviour, but that didn’t help, sadly.

The first screen shot is my code for the cursor and the second are the rough animation sprites.


I don’t know, the Events are you “Clicked” but i don’t know, make me know when you solved. this are really interesting! (Sorry for bad English)

1 Like

Hi, I haven’t used the Cursor Type behaviour, but by trying a little bit without that I just realized that you have to use the 'Trigger once while true" - condition when you invert the condition ‘cursor/touch is on’, like here:

(as in your case my cursor has three animations and in my example they are changed properly).

2 Likes

Hi Drona. Thanks for your help.

Sadly, that only solved half the problem. The first bit of programming with Clickable works perfectly, but the programming with Destroyable and Freezable still don’t quite work.

When the cursor hovers over either Destroyable or Freezable, the animation will change to 2 like it should, but it won’t change back to 0 like it should.

I tried deleting Freezable just incase having two objects with the same programming was the problem, but that didn’t solve anything, either. the cursor still wouldn’t change back for Destroyable.

EDIT: It’s weird, because I set these objects up in a second room and they all work perfectly. I wonder if I have to delete the objects in the first room and then put them back. I’ve had to do this before a couple of other times. I’m gonna try that tomorrow and see what happens.

EDIT: SOLVED! So it wasn’t the programming, yours was correct. I needed to delete the objects in the room and then put them back into the room.

1 Like