(Solved (kind of)) Game at runtime displays textures and images that don't exist

How do I fix this? Tried restarting gdev. The unwanted texture is the two blue squares touching diagonally. Wanted to add a picture of the game in the editor and in the preview, but I only can have one picture per post.

Add the second image of the game in the editor in a new post. And another of the scene events.

as you can see, there are multiple layers. the collision layer has all the single-color squares, and creates collision for the player. since the camera is not centered on collision, it does not display at runtime. interestingly, if you hit the hide layer button for collision, then the glitch goes away, despite the fact that collision layer objects should not ever be displayed!

the pictures in order are:
game at runtime with issue
game in editor showing collisionlayer and gui objects
my code for the level
entire map in editor with gui and collision showing
game in editor with collision layer hidden

Update: i made everything in collision opaque using events. this hid the weird texture, regardless of it’s origin.

So those two blue squares are on the collision layer, the layer is hidden and the blue squares are still visible? Sounds like the collision squares are not on the collision layer.

In your editor, can when you click on the two blue squares in your editor (as in the image below) - are they on the collision layer?

It might help if I include the image I’m referring to.

And I’m going on the assumption the 2 blue squares are those that I’ve circled in the image :