[SOLVED Kinda but SOLVED] Possible bug with new version - disappearing properties panel

UPDATE #4 I went into preferences to keyboard shortcuts tab and found toggle properties panel which was assign to P and just removed that shortcut well i never gonna use it anyway so who cares
And now properties panel do not close when changing songs with mouse
But what P had to do with it?
My mouse combo do not send any regular keyboard keys only media track next

UPDATE #3 I found what is causing it
I made this AutoHotKey script to change song when (for lack of what is proper name Xbutton1?) i hold thumb button the one under well thumb on side of mouse that is closer to my elbow and pressing left mouse button

And if gdevelop is focused it hides properties panel when i use that combo to change song
On xpadder (program to assign any keyboard/mouse/media button to gamepad) i have next song on right dpad button and it does not trigger hide
So only changing songs with mouse is causing it

Video if someone care

UPDATE #2 It happens randomly i’am trying to record it but it works perfectly fine but when i close OBS
It randomly just happen

UPDATE #1 ok so just to be clear again my layers panel is at bottom right above it is properties panel
If properties panel disappear then layers panel goes to the top
BUT i noticed that if i close gdevelop and reopen it then properties panel is back but instead of top left it is on button left (switched places with layers panel)
But as soon as i click preview button it disappears

So in short of it after last update
This version of GDevelop is: 5.1.158 (editor full version: 5.1.158-e5a710d7d51788f3028e5ccb2fe2848bb56c1e41, core version: 4.0.99-0-release)

I always had properties panel on the left right above layer panel
And it just disappear randomly after i try preview
I have set my preview to maximize window so i do not see editor i gonna turn it off to and see if i can spot moment when it disappear

As stupid as it is screenshots which only shows how it should look vs after it disappear but still proves nothing but it happened to me 5 times already
I did try to put it below layers panel but did not help