[Solved] Latest update destroys my resolution and music

After the update to 84/85/86 I have black borders left and right in my game.
On the mobile web and also desktop web version.
“Add an option to automatically resize game resolution to window or screen size. It’s recommended to activate it especially for games on mobile phones.”
Is that the problem? We already had this option in Game Settings.
If I now also use the action “Set Game resolution Mode to adaptWidth” it doesn’t help. I am already using the “activate fullscreen” action so it also runs in landscape on iOS.

Also the music booms since the update.

Resolution and music were really the most difficult things about my project and now both are broken.:cry:

1 Like

Sorry for breaking the game! Can you try to:

  • Remove all of your actions related to fullscreen/change the game window size/change the resolution, and use just the properties in game settings? You need to set it to adapt width and check the box to adapt if the game window or orientation is changed:

  • Alternatively, try not to use the “change the game window size” but the new “change the game resolution”.

Musics should not have changed though in the latest versions?


After activating the new checkbox, it works again. Merci! :slight_smile:
If I replace “Activate fullscreen” with “Automatically adapt the game resolution” I have black borders again, but I think that’s okay.

The Instagram app starts all links in chats and biography in their own internal browser. There GD Games on itchio are in portrait modus and very zoomed. But it is recognized as a mobile device.
Do you see any change to fix this?

The sound problem is 100% between b83 and b84/87.
I’ll test it later with a new project, etc.
Maybe my workarounds for the bugs that were fixed in 84 are now the problem.

edit: okay it looks random if the music sounds correct or not.
edit2: now i use global sound level instead of stop and play channel. looks like the music problems are now solved.

1 Like