[Solved] LDTK blank square in editor

When “importing” a test project from LDTK (witch are shipped with ldtk) (autolayers_1_basic) into Gdevelop everything is fine, it works and shows in the editor.

When i make my own tilemap using the example from LDTK as a base, but modifying it it will not work in Gdevelop.
When I import it and drag the object in the editor as an instance, it’s just a blank square…

I’m probably doing something wrong, but cannot figure it out.

Skjermbilde 2023-02-05 174048

IntGrid-layer type will be painted in Gdevelop editor, but not my “Tiles” layer

Are you on GDevelop 5.1.156 or newer? There was a bug on older versions that required a specific layer to be included (which the example projects had) that was fixed in 156.

Edit: Also note, Cloud projects do not currently support LDTK tilemaps because they cannot import the tileset correctly, so if you’re using a Cloud Project this is a known issue.

Thank you.
Ran Gdevelop as Admin and updated it to latest version.
That solved it.

1 Like