[Solved] MacOs / Problem with layers effects

Hi to the community ! GDevelop is awesome, congrats to the devs !

First, my apologies for my poor English. I’m French, so…
Anyway, I’m on Mac and I use the 5.0.0-beta92 release. My report concerns the layers effects : none of them seems to apply in the preview. I’ve tried many times on different layers, attempted to modify parameters, but without any results at all.
It’s annoying because this feature seems very useful.
Thanks for reading. Keep up the good work !

Kind regards,

Do the effects work on the web app for you? https://editor.gdevelop-app.com/
Try the effect Pixelate for example, I know that effect works.
Have you tried the network preview (with your smartphone)?

PS: The forum has a French section :slightly_smiling_face: If you have good recipes with croissants, frogs and snails, feel free to share :blush: :baguette_bread:

Some effect can have a strange effect if you game haven’t sprite as background.
The color background is not enough.
That why i recommend to everyone to test the effects on the Minda isometric game, instead the basic platformer.
What effect have you tried ?

Et oui n’hésite pas à faire coucou dans la section française, beaucoup de l’équipe sont sous drapeau tricolore :wink:

Hi Gruk,
I’ve just tried the web app and it worked ! Unfortunately, my internet connection is unstable, so I prefer to work on the local app. I’m new on GDevelop. Are the updates frequent ?
And for the recipes, well, there’s nothing better than a croissant from a true French boulangerie !

Salut Bouh,
I’ve tried the Color Map filter, in particular, and many others. There are sprites in all the layers I’ve tested. This afternoon, I’ve tried the GD web app, as Grunk suggests me to do, and there it worked fine. But even with the Minda isometric game, on the local app (on Mac), the effects still don’t apply at all.
Merci pour ta réponse. Tu veux que je recrée le sujet dans la section française ?

Some of effects like Displacement and Color Map require to use a file.

Thx for the link, but I had already read the document. Even with a file, these effects don’t work. In fact, none (I almost tried half of them) had any impact on the sprites of the layer. Maybe I miss something else ?
Thanks for your help.

@4ian you are on MacOS maybe you can help him more than us.

Which OS version, browser version are you using?
Probably WebGL is not working, and so the games are rendered in Canvas mode, meaning that effects are not working.
In a preview, open the Developer Tools (you can open it from the View menu) and send here a screenshot of the “Console” tab content so that we can verify this.

Hi 4ian,
I’m using High Sierra 10.13.6, the last update I could get on my MB Pro. My browser is Safari, but as I said, the problem appears only with the local app, not the online one.
Here is a capture of the console as you wished. I took only the part where all the errors are enlightened, I guess it’s what you want to see.

Be careful, this is a screenshot of the console of GDevelop. You need to make a screenshot of the console of the preview of the game :wink:

Hi arthuro555,
Sorry for the error, I misunderstood … So here is the new file. I guess the full red errors are just related to the management of files of my sprites which I have several times renamed / relocated. I applied three layers effects this time. I send you the screenshot in two times because of the limitation to one upload for the newbies.
I hope this time it’s enough for you to analyze, tell me otherwise.
Thanks a lot for your help.

And the next one…

4ian was right, as you can see on the first screenshoot, you can read

PixiJS 4.8.6 … Canvas

Canvas mean that the layer effects are not shown because these work only on webGL.

It doesn’t work in canvas because the effects require some aspect of a graphics card. I’m afraid that if you have a 2011 MB pro it’s too old, (High Sierra 10.13.6 is out in 2011).

Ok, problem solved ! Nothing to do except buy a new computer.
Thank you very much to all for the help.

If you see the effects in your browser that mean you can.
Maybe there is a way to force your computer to use the graphic card instead the processor, on a specific software, i don’t know if it’s doable on mac.

This is the same thing that happen to me on Windows 8 Pro after the new update 92 as i writed in this topic: [Fixed] [Layer effect] preview bugged - #7 by Venom
Before the update the effects was working and as @Bouh have writed i’ve noticed that on my screenshots there is writed “Canvas” also but in the web editor the effects work without problems.

Unfortunatelly haven’t finded a soluton at the moment on Windows :frowning:

Something similar was happened to me in the previous two/three months with Google Chrome, in fact the webgl on the legacy graphic cards has stopped working but fortunately with the latest update Version 81.0.4044.129 for 64bit in my case they have fixed it and webgl is working again.

I’m not a coder but can be something related to electron webgl support for legacy graphic cards?

In the next release of GDevelop the internal preview on desktop will use the tech from Chromium 80.0.3987.165

1 Like