[Solved] Platformer Infinite jump not working

This is my code.

Whenever I’m adding animation the character blips out of the game. Without animation the infinite jump is working fine. I’m unable to understand the problem here. Help would be appreciated.
(I can show video of the problem as well if any of you have Instagram or Facebook please ping me the ID as well)

what do you mean by this?

Or download something like ScreenToGif and post a .gif of what happens.

1 Like

i updated the post with the gif. please help

What do the 2 llama animations look like? Can you screen shot them in the sprite editor?

1 Like


Even looping the animation doesn’t work.

There’s nothing untoward with what you’ve shown already. Abnd I’ve recreated your events and have no problem. Could you try a restart of GDevelop?

If that still fails, what behaviours do you have attached to the llama object? And what is the collision mask like for the llama object?

In the GDeveop editor could you press ctrl + shift + i, then preview the scene. Are there any error messages that come up?

1 Like

I got it solved. There was a problem with the collision masks in the 2nd animation. Somehow it got reset every time I restart Gdevelop. I uninstalled and reinstalled and now the collision masks stay and it is working fine. Thank you very much for the time

1 Like