(SOLVED) Show Dialogue Options?

Dialogue options aren’t showing. I followed the tutorial below, but I can’t seem to know where I went wrong. Can someone else please take a look and see where the problem is?

I have seen similar forum topics on Yarn options, but none of them have been solved yet.

Dialogue in GDevelop with YARN - YouTube

Where are you setting the text of the DialogueOptions object? You show the object, but I can’t see anywhere where you set the text.

Ignore that, the method isn’t that intuitive.

Have you tried it with each option on a separate line?

1 Like

You have extra characters in your options (green) and the <<commands>> cannot be at the end like that, IIRC.

1 Like

Good news! I followed your advice and the options show up, now!
The Bad news is that, no matter which option I click on, the dialogue continues with the Help choice. So even if I pick the Fight choice, it acts like I picked Help, instead.

I noticed that the little arrow stays on the Help Choice. It doesn’t move with the cursor. I’m wondering if that’s the problem. I’ll try to figure that out on my own, but I appreciate any more advice. I posted a screen shot of my code so far on my first post.

I have and I’m afraid that didn’t work.
Thanks to Gruk’s advice, I got the options to show, but there seems to be a problem with making a selection, now. It only selects one of the options. I think it has to do with the arrow not following the cursor. I explained more in my reply to Gruk.

Hi there, to verify it’s not following the mouse choice try making events to change the choice selection of the dialogue.

Yarn doesn’t really have mouse support iirc, so you might use something like two invisible sprites to select one option or the other.



I corrected the formatting in YARN so the options showed up. I also changed the selection so you use the keys to pick and select instead of the mouse. Maybe I’ll change things in the future, but this good for now.

Thank you Mr. Men, Gruk, and Cat for you help!