[SOLVED] "Simulate key press" behavior when "ignoring default controls"

I will occasionally use “ignore default controls” in order to prevent the Player from moving (for example, at the end of a level, or when the game has been won). Works great. But with touch controls or a gamepad I use the “simulate” Actions to move the Player…and he still moves around when “ignore default controls” is activated. Is this as intended? I ended up using a variable instead (canmove: yes/no) but just wanted to make sure I’m not overlooking something.

This is intentional.

To elaborate: Default controls means arrow keys + space/alt/ctrl for the behaviors.

It doesn’t have anything to with the actions with those behaviors. The “Disable default controls” action is just toggling the same thing as the checkbox in the behavior. All other functions of the behavior are intended to work as expected. This allows you to have custom controls for your game/player/etc.

Hope this helps!

1 Like

Gotcha. I guess I assumed “disable pressing the physical Left key” would also “disable simulating pressing the Left key”.


1 Like

(Just as a small addition to the answer, instead of using a variable you can just disable the behavior in events)

1 Like