[SOLVED] "Simulate key press" not showing up in events so I can't add it!

Hello everyone. I’m making a top-down movement game with touch controls. I’ve assigned the top-down behavior to my player. I add the condition “The cursor/touch is on leftdpad (my left dpad)” and normally “simulate key press” would show up in the events under “top-down movement” but there is absolutely nothing so I can’t even add in my simulated key press to my dpad. Any help on how to get it to show up???

Simulate Key Press is an action, not a condition From your description it sounds like you’re searching conditions.

It doesn’t show up anywhere. I tried adding it as a condition and an action and it doesn’t show up anywhere. My command is “The cursor/touch is on leftdpad”, and when I try and input the action “simulate left key press” no controls show up at all. The program doesn’t even recognize that I have a top-down character in my scene.

I’m able to control my character with the actual left, right, up, down keys just fine, but when I try and go to search “simulate” for my action of “The cursor/touch is on ‘leftdpad’” nothing shows up at all. On youtube tutorials I’ve seen people that type it in with a top-down character and it shows up and they can put it as an action.

Never mind, i’m dumb lol. Went into the default platformer example to get a general idea and my stupid brain didn’t even select my player. I was trying to simulate a press for literally nothing so it wasn’t able to show up with the option to. Now I see it. Makes sense, im dumb lol. Fixed

You are not dumb, you only are new with GDevelop! It’s not the same.

1 Like

Hi, I renamed the topic to Solved