[Solved] Simulate pressing jump key not working on controller?

I tried simulating a jump key but it is not working for the controller only for the keyboard.

Just tested with Not-a-vania both locally and on the web demo at gdevelop.io

Both are working fine with my Xbox and PS5 gamepads.

However, the biggest issue I’m seeing is you’re saying “If the player is already jumping, and one of these things are pressed (Space/A button), then jump”

Your player can’t be jumping before they jump. Remove that condition (maybe you meant for it to be when they were on the floor?

Tried removing it, it is still not working.
Here is the other part of my project code maybe I did something wrong there?

Other controls are working just fine with the controller

I would launch Not-A-Vania from the examples and see if it works for you there.

Thanks for your help.

There it works well.

If it works in the examples, then it would have to be something specific to your project.

Sadly I’m not seeing any other glaring issues with your events. Can you show your updated control events?

There you go.

I tried it with left stick up and works now but still not the desired button sadly.

I see the issue now. You have “Button A”. However, it’s “Button “A””. If you open up that event you’ll probably see red text around your A because you’re missing the quotes.

Thank you very much I didn’t notice it. It works fine now. :slight_smile:

1 Like